Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Yamaha
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply Share this with your friends
  #1 (permalink)  
Old 09-27-2003, 04:47 PM
Cly Cly is offline
Weekend Warrior
Garage is empty, add now
 
Join Date: Aug 2003
Posts: 19
Default Blaster clutch wont work....need help

Hi all

I have a 97 blaster I was going to go riding today and when I wet out to load it up the clutch wont work.I took it apart an the clutch is not disengauging Im not real sure what makes it move out is it the threaded rod threw the center?How far should it move?any help would be great.


Thanks Cy
Reply With Quote
  #2 (permalink)  
Old 09-27-2003, 08:16 PM
Pro Rider
Garage is empty, add now
 
Join Date: May 2003
Location: Hiawassee, GA
Posts: 667
Send a message via AIM to ZBlaster
Default Blaster clutch wont work....need help

mine did the same thing u either need to tighten ur cable or the spring that engages it is broken.
Reply With Quote
Old 09-27-2003, 08:16 PM
Reply Share this with your friends

Tags
97, atv, blaster, clutch, release, wont, work, yamaha



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On