Go Back   ATVConnection.com ATV Enthusiast Community » SxS / UTV Discussion » Yamaha Rhino
Sign in using an external account
Register Forgot Password?
Search

Welcome to ATVConnection Forums!
Welcome to ATVConnection.com.

You are currently viewing our forums as a guest, which gives you limited access to view most discussions and access our other features. By joining our community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join the ATVConnection Forums community today!


Reply Share this with your friends
  #1 (permalink)  
Old 08-21-2009, 07:34 AM
Weekend Warrior
Garage is empty, add now
 
Join Date: Aug 2009
Posts: 3
Default Rhino Neutral Problem

Hello everyone. I'm new to this forum, and I am trying to help my friend with a problem with his Rhino660. The problem is that when he shuts it off, engine hot, then tries to restart, the neutral indicator dashboard light does not come on, even though the shifter is in neutral, and the Rhino won't start until it cools off. We have tried readjusting the shift linkage, but that did not help, and the actual shifting is OK anyway.The engine temperature seems to be within normal limits. The shifter housing on the engine, where the linkage connects, has what looks like a filler plug on top, but there does not seem to be any lubricant inside. The manuals we have do not say if any, or what kind of oil should be in there.
I'm thinking it might be the gear position switch. Has anyone had this problem, and can offer any advice? Thanks, Tom from Mass.
Reply With Quote
  #2 (permalink)  
Old 08-21-2009, 11:18 PM
atv parts plus's Avatar
Trailblazer
Garage is empty, add now
 
Join Date: Jul 2009
Posts: 38
Default

Neutral indacator switch sounds like its bad
__________________
"Never argue with an idiot. They drag
you down to their level then beat you with experience."

1100 cc sandblaster


Reply With Quote
  #3 (permalink)  
Old 08-22-2009, 02:32 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Aug 2009
Posts: 3
Default

Hello again. Yes, I agree it does sound like the neutral indicator switch. I know vehicles have these to prevent starting in gear. All I can find in the manual on the Rhino is a "gear position switch". According to the wiring diagram, it is in the starting circuit. I guess I will buy a replacement and see if that does the trick. Thanks, Tom from Mass.
Reply With Quote
  #4 (permalink)  
Old 09-08-2009, 08:13 AM
Weekend Warrior
Garage is empty, add now
 
Join Date: Aug 2009
Posts: 3
Default Update

Hello again everyone. Well, over the weekend we replaced the "gear position switch" and the problem is solved. This switch makes the connections for the high, low and neutral lights on the dash. It is located on the drivers side of the engine. The air duct must be partially removed to gain access. The switch cost about $ 65.00. This problem had been distressing because he could not start the machine when it was hot, and had to wait till it cooled down. He got stranded a few times. One interesting thing we discovered after talking with the parts guys at the local motorsport place was that you can start the Rhino in gear if you hold down the brake padal. He was not aware of that. Thanks for the advice. Tom from Mass.
Reply With Quote
  #5 (permalink)  
Old 09-10-2009, 09:55 AM
Pro Rider
Garage is empty, add now
 
Join Date: Oct 2008
Posts: 688
Default

That is exactly what I was going to ask, if it would start in gear with the brake applied.
Reply With Quote
  #6 (permalink)  
Old 09-24-2009, 12:18 AM
terb's Avatar
Trailblazer
Garage is empty, add now
 
Join Date: Sep 2009
Posts: 68
Default

good question!!
__________________
2012 XP850 Orange Madness
2012 CRF450X
2012 Yamaha WR 450
2009 Red Grizzly 700 EPS
2009 Silver Rhino 700
2008 Raptor 700 95HP
2010 Haulmark 28' race trailer
Reply With Quote
  #7 (permalink)  
Old 10-17-2009, 12:04 PM
terb's Avatar
Trailblazer
Garage is empty, add now
 
Join Date: Sep 2009
Posts: 68
Default

good queston!!
__________________
2012 XP850 Orange Madness
2012 CRF450X
2012 Yamaha WR 450
2009 Red Grizzly 700 EPS
2009 Silver Rhino 700
2008 Raptor 700 95HP
2010 Haulmark 28' race trailer
Reply With Quote
  #8 (permalink)  
Old 09-09-2011, 06:01 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Sep 2011
Posts: 7
Default big bear engine

The are some engine parts for 400 big bear engine
Code:
partsyahoo.com
I find 400 cc big bear ATV parts in
Code:
www.partsyahoo.com
and it is working well.
Reply With Quote
  #9 (permalink)  
Old 09-09-2011, 06:02 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: Sep 2011
Posts: 7
Default

Quote:
Originally Posted by YAMAHA400BigBear-Jianshe View Post
The are some engine parts for 400 big bear engine
Code:
partsyahoo.com
I find 400 cc big bear ATV parts in
Code:
www.partsyahoo.com
and it is working well.
Reply With Quote
Old 09-09-2011, 06:02 PM
Reply Share this with your friends

Tags
atv, contacts, find, hot, light, location, neutral, nuetral, problem, problems, rhino, shifting, start, wont, yamaha



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On