Go Back   ATVConnection.com ATV Enthusiast Community » Brand Discussions Area » Arctic Cat
Sign in using an external account
Register Forgot Password?
Register ATV Photos FAQ Members Calendar Search Today's Posts Mark Forums Read GarageVendors
Search
Welcome to ATVConnection.com ATV Enthusiast Community

Reply Share this with your friends
  #1 (permalink)  
Old 05-26-2010, 01:41 PM
Weekend Warrior
Garage is empty, add now
 
Join Date: May 2010
Location: Detroit, MI
Posts: 7
Exclamation 05 Arctic Cat 400 4x4 LCD display not working

My LCD display for my instrument pannel for some reason is not working at all. I have no idea what the problem might be, I checked around to see if there was a blown fuse maybe, but I had no luck finding a fuse box, or where the fuse might be. I do not have an owners manual at the moment I am going to order one soon, but does anyone have any ideas why the display is not working?
Reply With Quote
  #2 (permalink)  
Old 05-26-2010, 02:18 PM
cupsz71's Avatar
Pro Rider
2009 Arctic Cat 550H1 EFI
My Garage
 
Join Date: Jul 2008
Location: Minot ND.
Posts: 258
Cool

This works on the '06 + up models.....

Your fuse(s) are under the seat by the battery (I think). IF you find it - pull the 30amp accessory fuse. THEN remove the battery cables. Wait 5 min. Re-connect the battery and put the fuse back in.

You need to "wipe" the ECM memory to re-set the pod display. This method seems to solve most blank pod problems. If not - check your wiring harness up under the pod to ensure it plugged in to the gauge, and while your at it check ALL your wires running up the front of the handlebars/steering post for any wire chafe'n.

Hope this helps....good luck.
__________________
2008 TRV 650H1 (Mine) 1707miles

2009 550H1 EFI (Hers) 640miles

2009 250cc 4x2(The "Boys") 356miles
Reply With Quote
  #3 (permalink)  
Old 05-29-2010, 04:13 PM
Fossil's Avatar
"If you haven't any charity in your heart, you have the worst kind of heart trouble." ~Bob Hope
Garage is empty, add now
 
Join Date: Feb 2007
Location: Toronto Ontario area
Posts: 97
Default Service manual

You can download a free 2005 AC service manual which covers your 400 at the following link.

K&T Parts House Lawn Mower Parts and Chain Saw & Trimmer Parts
Reply With Quote
  #4 (permalink)  
Old 05-30-2010, 07:20 PM
Range Rover
Garage is empty, add now
 
Join Date: Mar 2007
Posts: 107
Default

The fuse box is down by the rear tire it is the right rear i think if you look at the inside of the fender you will see the fuse cover, two twist screws hold the cover on.
Reply With Quote
  #5 (permalink)  
Old 06-03-2010, 07:37 AM
Weekend Warrior
Garage is empty, add now
 
Join Date: May 2010
Location: Detroit, MI
Posts: 7
Default

The quad is in the shop right now getting the 4 wheel drive fixed. When I get it back this week I will check it out. Thanks for all the help guys!
Reply With Quote
Old 06-03-2010, 07:37 AM
Reply Share this with your friends

Tags
2007, 400, 4x4, arctic, artctic, atv, cat, fuses, guages, harness, manual, owners, seat, stopped, wiring, working



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On